Why upgrade SDK 3.0? Support for RAD (Rapid Application Development) and TDD (Test Driven Development) via HotswapAgent and JRebel Simpler SDK layout Jar packaging by default Support for Alfresco version 4.2 to 5.2 Integration testing webscripts TL;DR Update your pom.xml Remove all SDK modules, except for your jar/amp project modules. Update your Integration tests. Add integration-tests project module, and copy src directory. Re-organize your Integration tests into the integration-tests project module, and rename to